1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

SWR Bass 350 troubles...

Discussion in 'Amps and Cabs [BG]' started by soothsayer86, May 6, 2010.


  1. soothsayer86

    soothsayer86

    May 5, 2010
    NH
    My amp has a tube preamp. When I turn the gain knob, it sounds like static/crackles/noise in the background, which gets louder as I continue to turn up the knob. Can anyone tell me if this has to do with the tube itself? If not, what could be causing this ( i assume it is not supposed to be happening, and cannot be good for my speakers!:confused:) Any help would be greatly appreciated!
     
  2. noisenoisenoise

    noisenoisenoise

    May 3, 2010
    Does the crackle sound continue when you're not turning the gain knob? If it only crackles when you are turning the knob it is likely a dodgy pot. You can try cleaning it with a bit of contact cleaner (you can buy it a Radio Shack or any electronics hobby store) or you may need to replace the pot (if you're handy with a soldering iron you can do this yourself). I also have a SWR 350 and I love its sound. Hope that helps.
     
  3. soothsayer86

    soothsayer86

    May 5, 2010
    NH
    IIRC it does not continue when I am not turning the knob. I'll have to double check after work this afternoon.

    What type of cabs do you use with your 350?

    I am picking up a peavey 410tx this afternoon. I have heard very good things about the low end range of this cab, which is something my set up has been sorely lacking!
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.