1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Tascam 2x2 driver problems, Windows 10

Discussion in 'Recording Gear and Equipment [BG]' started by Alik, Dec 9, 2017.


  1. Alik

    Alik

    Apr 13, 2013
    El Paso, TX
    I bought this product, Tascam US 2X2 audio interface about less than a year, used it with Windows 7, had no problems with it. Now that I upgraded to win 10 (and downloaded and installed the new driver) my laptop just doesn't recognize it. Am I doing something wrong or this interface is just not compatible with win 10? Is anyone else having the same problem?
    Thanks in advance us-2x2_w_image_sm.jpg
     
    Last edited: Dec 9, 2017
  2. seamonkey

    seamonkey

    Aug 6, 2004
    Try ASIO4ALL
     
    Alik likes this.
  3. Alik

    Alik

    Apr 13, 2013
    El Paso, TX
    At this point, I'm considering replacing the 2x2 for a Focusrite 2i2 2nd generation, which has lower latency from what I've read. I had a Scarlett 2i2 first generation and was so easy to use. I regret selling it for making a few bucks.
     
  4. Bassist4Eris

    Bassist4Eris Frat-Pack Sympathizer

    I have that interface. What I have found is that any time I restart my computer, I need to unplug the interface and then plug it back in. For some reason, this makes the computer recognize the hardware once again. Hope this helps.
     
    Alik likes this.
  5. Ben B

    Ben B

    Jul 13, 2006
    San Diego, CA
    I doubt that it's a Win 10 compatibility issue. I have an old Tascam US-122 and it works on Win 10. This is a silly question, but you didn't mention if you rebooted after installing the drivers. Did you? Most modern USB device drivers do not require a restart, but some older drivers such as the driver for my US-122, do require a restart. Also, as @Bassist4Eris mentioned, you may have to unplug and plug in the device after booting the laptop.
     
    Alik likes this.
  6. Alik

    Alik

    Apr 13, 2013
    El Paso, TX
    No, it didn't work unplugging the unit.
    I'm done with it, just ordered a Focusrite 2i2 2nd generation
     
  7. DigitalMan

    DigitalMan Bring Back Edit/Delete Supporting Member

    Nov 30, 2011
    Bay Area, CA
    Try unplugging it and then deleting the device from device manager. Reboot and then plug it in. Sometimes windows loses track of devices, especially if the device has survived and OS upgrade or has moved from port to port. Even Focusrite devices experience this behavior, and sometime even Macs have the same problem.
     
    Alik likes this.
  8. Alik

    Alik

    Apr 13, 2013
    El Paso, TX
    Did that, but still have problems with it.
    Defective unit?
     
  9. Ben B

    Ben B

    Jul 13, 2006
    San Diego, CA
    Likely. I agree with your plan to replace it.
     
    Alik likes this.
  10. seamonkey

    seamonkey

    Aug 6, 2004
    Focusrite is nice interface. And you get focusrite support when you buy it new.
    They can help you work through any and all driver problems.
    Latency is low, but here too - get support as most problems are going to be something set wrong in in the control panel.

    Focusrite gives software freebies several times a year for hardware owners. Actual worthy good stuff.
     
    Alik likes this.
  11. Alik

    Alik

    Apr 13, 2013
    El Paso, TX
    I had a hard time getting the Tascam 2x2 to work on Windows 8.1, it required a lot of tweaking but in the end it ran ok. When I upgraded to Windows 10 it just died. Not even recognized by the OS. Well, I hope I don't get any problems with the Focusrite Scarlett 2i2 2nd Gen. Thanks for your help, guys :) really appreciate it
     
  12. Alik

    Alik

    Apr 13, 2013
    El Paso, TX
    This morning I remembered I have a pc running windows 7, so I installed the drivers, connected the US 2x2 audio interface (my bass plugged in) and guess what? Still not detected by the OS! Tascam 2x2 mixer says clearly No device connected.
    I contacted the Teac customer service, but since it's late December, holidays, etc, i think I'll have to wait a few days to have my email answered. :( I was only given a Repair number.
     
  13. seamonkey

    seamonkey

    Aug 6, 2004
    Guiseppe and Alik like this.
  14. Alik

    Alik

    Apr 13, 2013
    El Paso, TX
    Drivers installed perfectly but the Tascam 2x2 mixer didn't recognize the interface, neither any daw application. I tried every possible settings for it, both in the OS and 2x2 mixer, not to mention the daw apps. Nothing worked. If I get it repaired/replaced I'll have to let it go. In a couple of days I got the Focusrite Scarlett 2i2 2nd Gen coming in.
     
  15. Alik

    Alik

    Apr 13, 2013
    El Paso, TX
    Oh, yes, I installed Asio4all too, nope didn't work :thumbsdown:
     
  16. Alik

    Alik

    Apr 13, 2013
    El Paso, TX
    20180106_163728.jpg
    2i2 is in the house, not only was recognized immediately by the OS, but also it was declared as default recording device. I'm happy
     
    seamonkey likes this.
  17. whatizitman

    whatizitman

    Sep 9, 2014
    Yep. I even tried my focusrite solo on a raspberry pi a couple of days ago, and it recognized it. Wasn't stable, but that was a power issue. The solo will require a separate power supply for my project. But I'm pretty sure it will work.

    Frankly, I've avoided tascam interfaces. Several times I've been close to purchasing something when the price is good, but then decided against after reading reviews. It just seems like driver problems and compatibility issues are too common with tascam products (?).
     
  18. spantini

    spantini

    Jun 13, 2020
    Lakeland, FL USA
    I hope this helps someone. Better late than never, anyway..

    I'm running Win 10 with the Reaper DAW. I had been using my US-2x2 with absolutely no problems until one day, for (apparently) no reason at all, Reaper says "No Device Connected", and then it was as if the interface died. After many hours of troubleshooting all my hardware and connections, as well as multiple passes through all the DAW's preference settings, I found the problem..

    I recalled having clicked the "Update Now" button on the Tascam Settings Panel at an earlier boot-up - the panel had notified me of a new driver software version. I uninstalled the new version and re-installed the previous Version 2.11 and... BINGO! Now my systems recognize my US-2x2 interface once more. All has been well since.

    I have tried updating to all subsequent driver updates with the same results: "No Device Connected" - so I just re-install Version 2.11 and everything works fine again.
     
    Alik and seamonkey like this.
  19. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Mar 3, 2021

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.