1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

TC Electronics BH 800 Protective Mode qUESTION

Discussion in 'Amps and Cabs [BG]' started by rushfan73, Apr 25, 2016.


  1. rushfan73

    rushfan73

    Mar 9, 2007
    Manchester,MO
    Hi,

    I was practicing the other night at home, playing at a very low volume as my 4 year was asleep. I ran a passive p bass into a Sansamp Bass Driver Deluxe into the Bh 800 that was powering an RS 210. I was also running my laptop audio thru the aux input, again at a low volume. Suddenly, the lights across the front of the head start flashing like a spaceship or something, and I got a squealing sound from the speaker. I then shut it down, waited a few minutes and turn it back on again. All the lights come on, but no audio comes out of the speaker at all. I swapped cables and basses and nothing comes out of the speaker even though the lights are on and the on board tuner lights up as well. The cabinet I bought new in September, the head I bought used off of here around the same time. They have never been gigged or dropped or anything, does anyone have any idea what happened? Might I need a new head? Did the card just go bad all of a sudden?

    Thanks for any suggestions, I'll hang up and listen.
     
  2. IMO/E, with these types of situations (i.e., where an amp like this is showing a problem that does not have a published solution, reset/reboot sequence), the only thing you can do is contact the manufacturer.

    I had an issue with a BG250, where it lost output and all lights spontaneously went on steady. I was not asked to go through any troubleshooting or any type of reset sequence, they simply replaced the amp without saying what went wrong. I hope you're still under warranty. Good luck.
     

Share This Page