Too Much Rumble for ME!

Discussion in 'Amps and Cabs [BG]' started by bassturd, Jan 24, 2001.

  1. I have this problem with my ampeg head...

    I recently bought a 1975 Ampeg SVT head.(this sucker weighs a ton)...When I play through this thing it sounds way too bassy. When I adjust the knobs its still doesn't seem to make a difference. Its so bassy that it rumbles the heck out of my cab and the volume is only set at "2". My cab can handle a lot of bass (check out my profile) and I never had this problem with other heads. Anyone have a clue whats going on?

  2. rickbass

    rickbass Supporting Member

    Due to a gig that required me to fly in, I had to rent a rig in another city not long ago. Of those available for rent, I chose an SVT precisely because, IMO, Ampegs are one of the lords of subterranean sound.

    But, since yours is so elderly, as mom used to say, "you don't know where it's been." For that reason, I'd try finding something brighter sounding at a good tube site, . I'm no techie and that would be my approach before involving the expense of letting a tech dive into the guts of it. If that didn't work out, at least I'd have spare tubes I'd eventually need anyway. Or was yours verifiably overhauled by the seller?

    [Edited by rickbass1 on 01-25-2001 at 01:59 AM]
  3. Bassturd,
    turning the Ultra Lo switch off doesn't make a difference? Sounds like something wrong with the amp. I've got a '76 and it's got balls but I've got no problems rolling bottom end off. That doesn't sound like any problem I've ever heard with an SVT. Wacky, I'd bring it to a tube amp guru, it might just be something simple and easy to fix.
    PS, yup, they weigh a TON!!