Trace Elliot combo 'humming'...why?

Discussion in 'Amps and Cabs [BG]' started by RockingDad, Dec 27, 2007.


  1. RockingDad

    RockingDad

    Dec 13, 2007
    Hi,

    I bought a TE Commander 15 but when turned on it hums quite loudly. as i'm new to the bass amp thing can anyone give me any pointers as to why?

    It hums regardless of the bass plugged in or turned up/down. Volume controls on the amp have no change to the level of the hum.

    Cheers

    RockingDad
     
  2. billfitzmaurice

    billfitzmaurice Commercial User

    Sep 15, 2004
    New Hampshire
    Owner, Bill Fitzmaurice Loudspeaker Design
    It's broken. With nothing plugged in background hum should be barely noticeable.
     
  3. JimmyM

    JimmyM

    Apr 11, 2005
    Apopka, FL
    Endorsing: Yamaha, Ampeg, Line 6, EMG
    It's humming because it doesn't know the words ;)


    The only way hum should be noticeable is if you're cranking the tone controls all the way up. Then you'll get some hum that you can hear. But if the hum doesn't go away when you turn the tone controls to midpoint, then it's broken and you should take it back to the store.
     
  4. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Jul 24, 2021

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.