Trace Elliot Commando

Discussion in 'Amps and Cabs [BG]' started by I-Love-Ratm, Mar 19, 2005.

  1. I-Love-Ratm


    Feb 24, 2003

    I have the aforementioned combo.Pre Gibson I think.Well what I wanna now is when I play it sounds like something is vibrating somewhere on the speaker.Anyone know what I mean?Do you know what I could do to fix it?!?I love this amp and this problem can't be heard in band situation but ya know....


  2. Kelly Lee

    Kelly Lee Yeah, I'm a guy! Supporting Member

    Feb 17, 2004
    Marana, AZ, USA
    Check to make sure all mounting screws are tight.
    Check the dust cap for seperation.

    If its not one of those then I'm not sure what else it would be.
  3. picsures4ewe


    Mar 19, 2005
    hey if i play a guitar thru my bass amp what would happen?
  4. picsures4ewe


    Mar 19, 2005
    what would happen if i plug my guitar into my bass amp and play....?
  5. Quadzilla

    Quadzilla Supporting Member

    I had a Trace Commando head a while back (not a combo). I heard rattling from the head when I first got it and was playing it. I took it apart and noticed that the transformer in the head had 4 screws holding it together sandwich style and all 4 screws were loose causing the rattling sound. Not sure if this could be your issue or not. I would also take the grill off and tighten all of the speaker screws and grill screws, handle screws, etc, etc...
  6. I-Love-Ratm


    Feb 24, 2003
    Oh god I'll have to get someone else to do it I'd say.Don't trust myself
  7. Planet Boulder

    Planet Boulder Hey, this is a private Supporting Member

    Nov 10, 2001
    6,482 feet above sea level
    I once had impure thoughts. Oh, and I pluck my ear hair.
    Don't do it! It would be like attempting to play bongos with gloves on!

    NOTHING good can come from that!

    (insert winky here)