Trouble with Vox Valvetronix VT-30 Guitar amp.

Discussion in 'Miscellaneous [BG]' started by MisterWraith, Oct 14, 2011.


  1. MisterWraith

    MisterWraith

    Jul 15, 2011
    SW Florida.
    Hello,
    Over a year ago I picked up a brand new Vox VT-30 guitar amplifier for practice& home demo recording. At first I was thrilled at the great tone out of this little guitar amp. Eventually I noticed that after playing for a while the amp would start to cut out, go way down in volume and sound like crap. After going through the whole list most likely problems.... (I even put in a new pre-amp tube) I went on Google today and searched "Vox Valvetronix amps cutting out" It turns out there are a good number of posts from owners of various VT series amps who have gone through exactly the same thing...I was unable to find any solution to the problem. As a bass player this is my only guitar amp... I'm NOT HAPPY.. This post is specifically directed to other VOX Valvetronix guitar amp owners who have experienced the same thing. Do you know of a solution??? once again, this seems to be a defect specific to these particular amps, so I'm not interested in a re-hash of general trouble shooting techniques no matter how well intended.

    Todd
     
  2. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Jun 16, 2021

Share This Page