Troubleshooting buzzing on a Warmoth build with a Noll preamp

Discussion in 'Pickups & Electronics [BG]' started by micahwc, Nov 2, 2017.


  1. Greetings.

    After a lot of work trying to get this to work I've gotten to where it doesn't buzz as long as I have it in active mode and am touching the strings/bridge.

    When I switch it to passive it buzzes a lot. Further, there doesn't seem to be any passive tone control which it was advertised as having.

    I am running two American Standard Jazz V pickups wired together in permanent series, into the Noll preamp.

    The buzzing when I don't touch the strings is probably from the shielding which I am aware of already as something I need to work on. The control cavity has copper shielding and the pickup routes do as well, but I need to connect the pickup routes to the control cavity still and there isn't anything in the wiring passages. The shielding in the control cavity is all grounded.

    When I put the bass in passive mode there is a loud hiss, and then a very noticeable hum. In all fairness, I am sure my house is horrible for this. We have a dimmer switch in a room directly above my bass. The hum doesn't change wether I touch the strings or not, it just has this constant pervasive hissing. Like seriously, the worst I've ever heard in 20 years of playing.

    Any suggestions for what to look for? I've checked all the wiring and it all appears good to me.

    Thanks in advance.
     
  2. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    May 23, 2022

Share This Page