Waving the White Flag: Wiring Help Needed

Discussion in 'Pickups & Electronics [BG]' started by <MrVentures>, Jul 16, 2021.


  1. I have an inexpensive active bass that I use during the summers, and I decided to create a learning project for myself: shield everything with copper tape and replace the preamp with a Delano Sonar 3 MS. Important note: I have never done this before and am completely new to wiring, soldering, etc.

    When I got to the “end”, everything seemed to be working and I was getting a consistent bass-sound out of the jack. However, I realized that there was no sweep to the volume pot: either it was on (around 9) or off (every value below 9). It’s a push/pull pot as well, and there is no sound coming out when in passive (pull) mode. Every other pot works, including the balance. The balance pot was the only other pot not pre-wired, so I had to so some soldering on that too.

    I did my best to read up on this and avoid reaching out, and the symptoms seemed to be those of a bad volume pot, potentially due to overheating during soldering. So I ordered a replacement, was very careful with my soldering, and now I have the same issue. It makes me think the issue is somewhere else, but I have no idea where to look.

    I’ve attached some photos, but I found it rather difficult to get a clean shot of everything since it’s all crammed in and tiny. Apologies for the wiring mess!

    Any thoughts on what could be causing the issue? Any further information or photos I can provide?

    Thanks in advance.

    p.s. Here is the wiring diagram I am following.

    3F12D229-BACB-4A43-9A8C-E1FE4C5289C7.jpeg 15385CBB-C1FE-4C6C-B5D0-CF4A778CAA76.jpeg F9C84D5C-ED94-42C6-A72C-C3431ADA73A8.jpeg 38925FF3-29C0-4696-AC90-1E5487CC8DC5.jpeg 02B56087-F8E1-4D4B-8A9F-F55B77686D36.jpeg
     
  2. adamrobertt

    adamrobertt Supporting Member

    Dec 14, 2007
    Pretty hard to tell what's going on from those photos. But I did notice that you don't have the rightmost lug on the push/pull connected to ground. You should run a wire from that lug to the copper shielding.
     
    <MrVentures> likes this.
  3. Crater

    Crater

    Oct 12, 2011
    Dallas, TX area
    This is correct, you need to connect the third terminal of the volume pot to (a) ground/earth.
     
    <MrVentures> likes this.
  4. Thanks; I’ll try that tomorrow. I had it connected on the previous volume pot but it appeared to make no difference, though that pot could have actually been bad.

    I checked with a multimeter and I have continuity. Same with the other pots - they are all digging into the copper tape so I didn’t run a ground wire for any of them.
     
  5. adamrobertt

    adamrobertt Supporting Member

    Dec 14, 2007
    Yeah as I said, it may not be your actual issue, but I never trust that contact with the shielding is enough. In theory it does work, but over time who knows if it'll stay connected if the pot rotates or shifts a little bit, or if the shielding oxidizes etc. I always run a wire at points like that anyway just to be safe.
     
    <MrVentures> likes this.
  6. Just ran a ground wire from the third terminal to the shielding and I still have the same results.

    Where else can I check? Could there be something connected to the volume pot (e.g. the blend pot) that I should be checking?
     
  7. Potential points for soldering issues?

    347A2F92-CC76-4BA9-95DE-45F3B73BB97E.jpeg 516AD123-9438-4BD2-94C5-EE36D952F926.jpeg
     
  8. I just went through and resoldered everything, made sure all grounding wires were in good shape and everything is continuous. Still have that same issue: volume only at 9 and above; passive volume barely audible when volume pot pulled; all other pots working as expected, no buzzing/crackling/etc.
     
  9. Haroldo

    Haroldo Supporting Member

    Aug 31, 2005
    North Shore, MA
    Draw a schematic based on your wiring. Compare that schematic to your wiring diagram. Look for inconsistencies.
     
    <MrVentures> likes this.
  10. Good tip. Will take some time, but could be worth it.
     
  11. Bonafide

    Bonafide RGJR Gold Supporting Member

    Oct 15, 2002
    Central TX
    Artist - Nick Silver Pickups, Band In A Box, D'Mark USA, Free The Tone, Carr Amps + more
    Your volume pot is still not grounded. I can see from the new pic, the outer most lug of the volume pot still needs to be grounded. (Or if it is, I cannot see the wire)
     
    <MrVentures> likes this.
  12. Sorry, it is grounded, it just wasn’t visible in the new photos.


    Took a shot at it. Still don’t see anything wrong. The only other thing I haven’t tried yet is running ground wires from the EQ pots to the cavity. They appear to be grounded (and work as expected), but could that cause a problem with the volume pot?

    BFC9672B-2080-48EA-9773-F9C8D4CBCDBF.png 7903752D-E08F-4B1B-ACA9-B2EAC4C6B749.jpeg
     
  13. dwizum

    dwizum

    Dec 21, 2018
    No. The only reason to ground the cases of the EQ pots is for shielding. It's not part of the signal path in any way.

    What value volume pot are you using?

    Is it still not working in passive mode?

    I'd be tempted to test the circuit with a standard volume pot, hard wired to passive. See if it works. Then hard wired to active.
     
    <MrVentures> likes this.
  14. Bonafide

    Bonafide RGJR Gold Supporting Member

    Oct 15, 2002
    Central TX
    Artist - Nick Silver Pickups, Band In A Box, D'Mark USA, Free The Tone, Carr Amps + more
    Your diagram does not match the schematic. The ground, in, out, 9v wires to the preamp do not match the schematic.

    7903752D-E08F-4B1B-ACA9-B2EAC4C6B749.jpeg BFC9672B-2080-48EA-9773-F9C8D4CBCDBF.png
     
    <MrVentures> likes this.
  15. I’m so sorry, you are correct — the drawing was a bit sloppy in that area. I was looking at a photo I took of the preamp and it was hard to see the exact order (some pressure to be down with the wife…). These cables were all pre-wired (so in the correct order), but I wanted to match the colors on these ones. I’ve corrected the errors in the drawing but didn’t change anything on the bass.

    C8144D4B-7F35-42F2-AECF-701D04F74FB1.png

    It’s an Alpha 250k audio taper. Passive mode still doesn’t work. The little piece that flips on the bottom of the volume pot when you pull the pot still works (it doesn’t on the original volume pot).

    I’ll have to order a standard volume pot to test it, but could be worthwhile.
     
  16. dwizum

    dwizum

    Dec 21, 2018
    Or, honestly, just hardwire without a pot. Try each way. Determine if the wiring works passive and if the eq works in active mode. That'll tell you if the issue is with the pot and it's wiring or somewhere else. All this effort concentrated on the volume pot, and a short somewhere else could make it seem like it's the pot when it isn't.
     
  17. This is what I'm wondering -- is there anywhere else besides the volume pot that could cause this particular issue? Apologies for the potentially basic question, but how do you hardwire something without a pot?
     
  18. dwizum

    dwizum

    Dec 21, 2018
    Take the push/pull pot out of the picture.

    Try these three configurations:

    1) Passive with the EQ totally disconnected: leave the green wire on the EQ unconnected. Connect the green "hot" wire from the balance control directly to the jack. Take the battery out. The bass should work like a normal passive bass, but you won't have a volume control. The blend control should work. If the bass doesn't work at all like this, there's probably a bad connection in or around the blend pot - either something is disconnected, or there's a short to ground.

    2) Passive, with the EQ connected. Leave the battery in. Connect the green wire from the blend to both the green wire from the EQ and to the jack. The bass should work exactly as in #1, you shouldn't notice a difference. If there's a difference, there's a problem with the EQ or it's wiring.

    3) Active. Connect the green wire from the blend control to the green wire from the EQ. Connect the yellow wire from the EQ directly to the jack. It should work 100% as usual, as an active bass, with all the active controls - only difference is, no volume control.
     
  19. Thanks for the descriptions of each scenario, @dwizum! Will try these out and see what I find. May take a little while as I will be away from the bass for a bit.
     
    dwizum likes this.
  20. Unfortunately, I wasn’t able to get this figured out due to lack of time. I did find an issue with the output jack: if the cable was moved in a certain way, the connection would be lost. So I was able to fix that, and again resoldered all joints and hoped that would fix the volume pot problem…but no luck. I was able to fix the output jack, but now back to square one with the volume pot. I had to leave it there as it was time for me to leave the U.S. (and the bass), so I will pick it up again next summer. Was planning to change out the MM-style bridge pickup anyway, so I’ll try again then.

    I will say that the Sonar made a huge improvement to the sound - very happy with it and so glad I made that decision. Thanks again for all of your suggestions and advice; I hope to apply it all when I return!

    edit: fixed typo
     
    dwizum likes this.
  21. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    May 23, 2022

Share This Page