Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Weird sound coming from my tweeter

Discussion in 'Amps and Cabs [BG]' started by bassman1185, Aug 6, 2003.


  1. I've got an Ampeg BA-115 (1x15 with tweeter) and it seems to be making a strange sound from the tweeter. It's a sort of fuzzy, distorted sound. The strange thing is, it doesn't do it all the time, so I don't think that the tweeter is actually blown. Anybody know what's going on?
     
  2. baggpuss

    baggpuss

    May 28, 2003
    Hull, UK
    errrrrrrrrrr
    really out on a limb here.....
    could be an intermitant earth problem with ya amp or bass causing high pitch interfearence......
    and that is what is called a shot in the dark:confused:
    sorry cant be of more help....

    Dale
     
  3. cjgallen

    cjgallen

    Oct 19, 2001
    Could be a bad l-pad
     
  4. OK, so does anybody have any idea of what I might be able to do to fix it?
     
  5. tornadobass

    tornadobass Supporting Member

    Nov 20, 2000
    Iowa City, Iowa
    Endorsing Artist: Black Diamond & SuperSensitive strings
    Piezo horns are very inexpensive and can even be bought at Radio Shack (but try Parts Express online).

    These are usually all or nothing for function.

    I should add that the BA115 has a lot of hiss with the horn on...a bit like listening to a seashell. Is the noise like that?

    Also, you'll find a cab with a horn will let you hear stuff you never heard if you've only had a cab without one.
     
  6. No, I already kow about the normal hissing that the horn makes. This is a more distorted, fuzzy sound. It sounds like I'm running a little bit of fuzz through my amp.
     
  7. I've had exactly the same problem with the tweeter of my yorkville bm200!! It's a fuzzy sound, but ugly, with a lot of treble (I know; it's a tweeter :p ) I only hear it once in a few months and when I turn the power off and switch it back on, it's gone most of the times. I think it has something to do with earthing. For me it isn't really a problem, because it only happens once and a while. Can't help you any further, sorry :meh:
     
  8. Sounds like a weak battery in an active bass.

    Do you hear the same fuzz through other gear?