1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Whats wrong?

Discussion in 'Ask Janek Gwizdala' started by BassMann2112, Mar 2, 2008.


  1. BassMann2112

    BassMann2112

    Jun 21, 2002
    My Trace Elliot AH300 GP-SMX-12 head has no volume. It sounds destorted as hell and can achieve no volume. Anyone know what might be wrong with it.

    I have had this head since 1996. A few months ago I brought it to a friends house and connected it to 1 PA speaker bottom, 15" -300watt. After playing a few tunes it just dropped out with the above symptoms. I guess I will have to get it worked on now. Thank god I also bought the Trace Elliot V4 tube head about 8 yrs ago. A much better tone all together. However, I still love the AH300 GP-SMX-12, and need to get her running again.

    Any help or ideas woulg be much appreciated.

    Thank You, BASSMANN2112
     
  2. fenderhutz

    fenderhutz Supporting Member

    Jan 28, 2007
    Harpers Ferry WV
    Janek doesn't answer my gear is broke requests.
     
  3. janekbass

    janekbass

    Jan 28, 2004
    Los Angeles
    Founder and CEO of http://janeksbassstudio.com
    yeah, sorry. But I posted a sticky about this on the top of the forum.

    I really don't know anything about gear, so it's no the place to post gear questions.

    There are so many more qualified people on this forum that could answer your questions.

    Easy,

    Janek
     
  4. BassMann2112

    BassMann2112

    Jun 21, 2002
    Well now thanks for the etiquette lessons here fenderhurtz, I was just trying to get the question out to different post pages thats all. How would you have felt if I posted it on all of the post categories. Llighten up and have a nice day
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.