When ampeg stop putting a FX loop in the SVT CL

Discussion in 'Amps and Cabs [BG]' started by Mudfuzz, Jul 26, 2005.

  1. Mudfuzz


    Apr 3, 2004
    I’m just curious, what year did ampeg stop putting the FX loop in the SVT CL?

    Last week I read around here that the SVT CL doesn't have a FX loop, and thought it odd because mine does [I have a early nineties one, which I got new in 98] so I checked “peg’s” site and sure enough no loop. So why the de-evolution?
  2. the original SVT's didnt and i didnt think any of them did actually, hmm
  3. cb56


    Jul 2, 2000
    Central Illinois
    Just a thought but the SVPCL pre amp has no effects loop. maybe that's what you read.
  4. Yes it's the preamp that has no effects loop, not the head.
  5. Mudfuzz


    Apr 3, 2004
    This what I thought as well but........

    Hence my confusion. So it's either they did take out the FX loop, or someone made a mistake in the specifications on their site, which either way is a bit boneheaded IMOP.
  6. Theres more than one mistake on the ampeg site im sure, you seen the state of thier forums :scowl:
  7. Jerrold Tiers

    Jerrold Tiers

    Nov 14, 2003
    St Louis
    The site is right, sort of..........

    Its a matter of definitions...............

    There is a preamp out / power amp in pair of jacks. That isn't LABELED "effects loop" and it isn't before the master in the preamp..... soooooooo .........rigidly and legalistically thinking deep in the left brain, it isn't an effects loop............ :rolleyes:

    But its the same dang thing................ Grrrrrrrrrrrrr........