1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

WHY!? Does it refuse to ground!

Discussion in 'Pickups & Electronics [BG]' started by Forcemaster, Sep 27, 2008.


  1. Forcemaster

    Forcemaster Supporting Member

    Jul 15, 2006
    Portland, OR
    I have a Geddy Lee Jazz bass that is giving me some grounding troubles.

    There's no hum as such, (apart from the obvious single coil hum) but whenever I touch any metal parts I get that annoying clicking sound out of my amp telling me something's being grounded.

    I took off the control cavity and bridge to investigate further, when I physically hold the end of the ground wire the click no longer appears, yet when I place it under the bridge the click reappears! I'm really frustrated with this at the moment. Could be a case of replacing the ground wire?
     
  2. slyjoe

    slyjoe Supporting Member

    Jun 28, 2008
    Valley of the Sun (AZ)
    Sounds like the wire is not making good contact with the bridge. If you have an ohmmeter, ensure there is conductivity between the bridge and output jack when the bridge is installed.
     
  3. YOU are grounding to the bass. I think your bass is working fine.
     
  4. Forcemaster

    Forcemaster Supporting Member

    Jul 15, 2006
    Portland, OR

    I don't have an ohmmeter unfortunately, but that could well be a possibility. What would be a course of action if this were the case? Replacing the ground wire?
     
  5. slyjoe

    slyjoe Supporting Member

    Jun 28, 2008
    Valley of the Sun (AZ)
    Hard for a wire to go "bad". Not so much a replacement - make sure there is enough insulation stripped off at the bridge end. Maybe even ball it up a little to make sure it is always making contact with the bridge. Don't have the wire sitting only in the slot for the hole to the control cavity.

    ETA: you can also verify the problem with another wire - with everything installed, wrap a wire around the outside of the output jack and wrap the other end around a part of the bridge. This isn't a real good connection, but at least you can see if it solves the problem.
     
  6. Thangfish

    Thangfish ...overly qualified for janitorical deployment...

    If the ground wire was not making contact with the bridge, touching the bridge with your finger would have *zero* effect.
     
  7. Forcemaster

    Forcemaster Supporting Member

    Jul 15, 2006
    Portland, OR
    That's true. And I do get the sound when I touch the bridge.

    So what is the issue here?! A control cavity problem?
     
  8. Thangfish

    Thangfish ...overly qualified for janitorical deployment...

    Don't know. Static electricity, maybe?
    If so, I've seen dryer sheets used to lightly wipe around on the ax to dissipate it.
    Cable/jack going flaky?
    Amp grounded through wall plug, to a ground that is actually connected?
    Really don't know. Just shooting in the dark now.
     
  9. gbarcus

    gbarcus Commercial User

    Jul 20, 2008
    Minneapolis & St.Paul, MN
    Owner of Barcus Basses barcusbasses.com
    I've had a similar issue, and it turned out to be that the amp wasn't grounded (had no ground wire on the plug). So when I touched it, I became the ground. I tried a different amp that I knew had a ground and it worked fine.
     
  10. RyreInc

    RyreInc

    May 11, 2006
    Kalamazoo, MI
    I've had a similar experience with amps with a lifted ground. Simultaneously touching the bridge/strings and the concrete floor resulted in either a pop and/or an electric shock--you definitely wanted to wear rubber-soled shoes!
     
  11. Forcemaster

    Forcemaster Supporting Member

    Jul 15, 2006
    Portland, OR
    This is interesting because I have these problem only occasionally in different places, i've used my amp in different venues and had no issues, but also still had them. This is extremely frustrating!
     
  12. Forcemaster

    Forcemaster Supporting Member

    Jul 15, 2006
    Portland, OR
    Another thing worth mentioning is my bridge wire is grounded to the bottom of the control cavity not any of the pots or anything, could this potentially be the problem?
     
  13. slyjoe

    slyjoe Supporting Member

    Jun 28, 2008
    Valley of the Sun (AZ)
    Yes, that could cause a poor ground. However, as others have mentioned, it almost sounds like an amp grounding problem.
     
  14. Forcemaster

    Forcemaster Supporting Member

    Jul 15, 2006
    Portland, OR
    It does. But unfortunately i've played it through other set-ups in different places and it's still given me the same sound! Going to see about getting it resoldered to somewhere else. Would soldering the bridge wire to the output jack solve my problem?
     
  15. slyjoe

    slyjoe Supporting Member

    Jun 28, 2008
    Valley of the Sun (AZ)
    Don't know if it would solve your problems, but IMHO that is a better, more solid ground.
     
  16. Are you still having this problem?

    I had something similar happen to me once. Boy, did I feel stupid when I figured it out...

    I was sure everything was hooked up right, so sure that I never checked my output jack conections.

    Turns out they were backward! DOH!

    Things will work but you can get that buzzing sound when you touch anything metal... strings, bridge, etc.

    I don't know it that is what's going on with your bass but you might want to double check the simple stuff too.

    Later
     

Share This Page