1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

03 Warwick Streamer Jazzman "hum"

Discussion in 'Basses [BG]' started by sleevey55, Nov 4, 2013.


  1. sleevey55

    sleevey55 Supporting Member

    Nov 21, 2009
    Billings Montana
    Got to a gig last week and when I plugged in my bass it sounded like it does when you turn your amp on and have the cord plugged into the amp but not the guitar........pretty loud humming/buzzing like a horrible ground or something???? I changed the battery, and visually inspected the solder connections....but I dont see anything obvious. I DO NOT want to send it off to anywhere as its mint and I dont want to ship it, fearing damage (my luck). Is this something a decent guitar tech should be able to track down OR do I send it off to Warwick???????
    Any ideas guys? By the way, the bass plays when plugged in and sounds great, its just when you stop, the noise becomes obvious.

    Thanks:rollno:
     
  2. WaskoDS

    WaskoDS

    Nov 22, 2009
    Allentown, PA
    Odds are that the jazz pickup in the neck position is a single coil. While two RWRP single coils will buck hum when evenly balanced, a single coil cannot cancel noise when mixed with a humbucker. You could replace the neck pickup with a split or stacked jazz pickup. There was probably fluorescent lighting at the gig you played, or the pickup cavities of your bass aren't shielded well/at all.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.