1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Amp question

Discussion in 'Amps and Cabs [BG]' started by VTheHTyphoon, May 4, 2010.


  1. VTheHTyphoon

    VTheHTyphoon

    May 4, 2010
    I have a question about cables, and about if I am underpowering my amp. I have an Ampeg American Made BXT-410HL4, rated for 600 Watts RMS at 4 ohms and a Line 6 HDLowdown 400 head rated at 400 watts at 4 ohms. My first question is will I damage my speakers on the Ampeg if I am not driving my head at the full 400 all the time and pushing it as close to 600 as possible, or can I play it at reasonable levels and not worry about my speakers ruining? My second question is about connecting the cables. On the back of both the head and the cabinet there are two speakon connectors. do I connect both or do I only use one cable? And if I do only connect one do I connect it right to right or what configuration do I use? thank you in advance.
     
  2. Try reading the FAQ's? :) Here we go again :scowl:
     
  3. You only need to use one cable. Should be any configuration. And you will NOT damage your cab. Under powering does not exist except in special circumstances.



    -RTK
     
  4. VTheHTyphoon

    VTheHTyphoon

    May 4, 2010
    to b-string, I did read the FAQs, but I wasn't sure how it applied here.
    and to RTK thank you very much, I was really happy to find a brand new American made ampeg pre-2007 so I didn't want to let it go by
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.