Ampeg SVT-CL - Bias or power tubes?

Discussion in 'Amps and Cabs [BG]' started by bhoff5150, Jan 16, 2018.


  1. Long story short, I purchased a US made SVT-CL on craigslist about a year and a half ago. The amp has been great and the greed LED bias lights on back always lit up on both sides. I noticed the other day that now only one of the green LEDs is lighting up. So during a band practice (letting it warm up properly) I tried adjusting the side that wasn't lighting up and no matter what I did I couldn't get it to illuminate. The amp does sound like it may have lost a small amount of punch, but when the tubes to out in my V4B, you can tell pretty quickly.

    Does this mean that matched tirad of tubes needs to be replaced on the side that is not lighting up? Or am I somehow not biasing it correctly.

    Has anyone else had this same issue and if so what was your fix?

    Again the amp doesn't sound terrible, but it might lack a tiny bit of definition.
     
  2. Jim C

    Jim C I believe in the trilogy; Fender, Stingray, + G&L Supporting Member

    Nov 29, 2008
    Bethesda, MD
    Does the other LED show red or is it completely out full time?
     
  3. rickdog

    rickdog Gold Supporting Member

    Mar 27, 2010
    Try swapping the two triads of output tubes. If the problem follows the tubes, you probably have at least one bad tube. If the same bias indicator still has the problem, there's an issue in the power amp circuit board.

    Has the amp ever gone into fault mode (flashing red/green front panel LED)?

    What's the history of the set of tubes? What are they? Are they all identical?
     
    JimmyM likes this.
  4. coreyfyfe

    coreyfyfe Supporting Member

    Nov 19, 2007
    boston, ma
    I would swap the 12AU7s first. Often if the bias lights won't come on at all the 12AU7 driver has failed. If you swap the 12AU7s and the alternate side works/doesn't you've found your problem.
     
    JimmyM, rickdog and beans-on-toast like this.
  5. Chris Breese

    Chris Breese Supporting Member

    Dec 12, 1999
    Farmington, IL USA
    I had the same LED problem. I kept using it until it faulted out on me. Shut it down and took it to my repair guy. Still waiting to hear from him.
     
  6. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Sep 24, 2021

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.