1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Getting radio interference!?

Discussion in 'Amps and Cabs [BG]' started by jiant., Feb 17, 2005.


  1. jiant.

    jiant.

    Jul 3, 2004
    Fort Mill, SC
    When I hooked up my newly aquired Sabine tuner to my amp, I started to get a radio signal coming through my cab. It only happens when I am running my guitar into my tuner, and then connect the tuner's amp out to the insturment input on my amp. Could this be caused from not using shielded cables? I don't know if one of them is shielded or not, because it is just some random small cable that was left at a show that I picked up. Any ideas as to what I can do to get rid of this are welcome. Thanks and God bless.
     
  2. BillyB_from_LZ

    BillyB_from_LZ

    Sep 7, 2000
    Chicago
    Yes, you should use shielded cables that are in good condition.

    You could probably drive the input of the tuner with the line output of the Behringer head, but you wouldn't get a mute function (if you have one now).

    Sounds like either a shielding or a grounding problem somewhere.
     
  3. jiant.

    jiant.

    Jul 3, 2004
    Fort Mill, SC
    yeah, i want to be able to use the mute. I'll pick up some new cables tomorrow. Thanks and God bless.
     
  4. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Jan 16, 2021

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.