Helicore Hybrid A string problems

Discussion in 'Strings [DB]' started by Sean Riddle, Mar 23, 2014.


  1. My bass at my high school is currently strung with Helicore Hybrids. They've been handling fine until recently. When I bow the A string, my bow barely grabs the strings and a harsh metallic noise is produced. I've cleaned my strings to see if that was the problem and it didn't help one bit. Has anyone else had this problem with the A string or could it be a personal problem with my technique?
     
  2. eerbrev

    eerbrev

    Dec 6, 2009
    Ottawa, ON, CAN
    have you had a big change in humidity recently? if so it might be being affected by a wolf.

    if not, the string may have gone false. time for a new string.
     
  3. Yes, the weather in my area has been really bipolar lately (one week cold then the next hot). They are about a year old, so I'm gonna go with weather.
     
  4. eerbrev

    eerbrev

    Dec 6, 2009
    Ottawa, ON, CAN
    Do your best to keep your bass in as stable of an environment that you can. Keep it in its case, that sort of thing, try and keep it out of super dry and super-humid areas.
     
  5. daddarioorch631

    daddarioorch631

    Jan 27, 2014
    Farmingdale, NY
    Product Specialist, D'Addario & Co.
    Hi there! I work for D'Addario, and I'd be happy to get this issue fixed for you. Please feel free to message me or email me if you continue to have problems.

    [email protected]
     
    nicechuckh and pmad_bass like this.
  6. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Jul 30, 2021

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.