HELP Clarus users ! Click sounds ??

Discussion in 'Amps and Cabs [BG]' started by jlsbass, Sep 22, 2003.

  1. jlsbass


    Aug 8, 2003
    Hi all, this is urgent cause I don't have much time to return it if bad ...

    I just got a used Clarus 300ia head and need to know if its in working order or not ...

    I get speaker sound clicks whenever I plug into the amp head ... this is despite ALL the knobs turned all the way down (including on the p-bass itself)...
    It also clicks when turning the clarus off.

    Is this normal for the clarus to do this ? I don't want to hurt the new speaker I just got (EA 110).

    Thanks a ton in advance,
  2. thrash_jazz


    Jan 11, 2002
    Ottawa, Ontario, Canada
    Artist: JAF Basses, Circle K Strings
    Hey there fellow Ottawa-ite,

    Is the amp working at all, or do you ONLY get click sounds?

    Mine had the same problems when I got it (used). Turns out it had two busted MOSFETS.
  3. fretlessrock

    fretlessrock Supporting Member

    Aug 8, 2002
    Mine doesn't do that and it is one of the older (series 1) models. I'd give AI a call and see what they think. I haven't had to use it but I hear that their customer service is very good.

  4. jlsbass


    Aug 8, 2003
    Yes the amp seems to work ok ... but when everything is turned down - I plug my bass in or my effects pedal in ... it does the pop/click thing for an instant ... then behaves normally.

    This is a series I amp ... just got it a few hours ago ... my first amp of ANY kind.

    John in Ottawa.
  5. erik II

    erik II

    Jul 11, 2000
    Oslo, Norway
    Generally I get a weak pop about a second after turning on. Hardly noticeable with the volume down. With the volume up: Pops a bit louder, plus the pop is followed by a faint, slowly fading crackle. The crackling seems to occur only when the amp is cold.

    No noise when plugging bass in or out of amp, even with volume up.

    So this has never bothered me. Yours is obviously making more noise. I can't say if it will harm the speaker or not.
    Shoot an e-mail to AI, I've sent them a couple of questions and got quick and thorough responses.

    Good luck.
  6. jlsbass


    Aug 8, 2003
    Hi again, still evaluating ...

    Seems to make the worst POP when turning the unit OFF ...

    I tried just turning off the power bar instead of the clarus's on/off switch ..., but was the same thing ... did not help ...