1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Mesa Titan power indicator light died

Discussion in 'Amps and Cabs [BG]' started by Thevolumedealer, Nov 3, 2013.


  1. Thevolumedealer

    Thevolumedealer

    Dec 21, 2008
    Anyone know or have a link to get a new one? The amp is fine but the light appears to be blown. Hopefully nothing else is going on. I'm a little anxious to be truthful because I've sent it back to Mesa twice since I've had it for various issues.
     
  2. Called Mesa yet?
     
  3. Thevolumedealer

    Thevolumedealer

    Dec 21, 2008
    Not yet. I have a point of contact from my prior issues though. I was hoping I could get a link to a new one and just purchase it rather then contacting Mesa as I'm sure they are pretty busy and this bulb issue appears to be pretty trivial (I hope).
     
  4. Mesa sells spare parts and are never too busy to support their customers ;). If there could be an underlying problem they would know and save you some time and cash. :)
     
  5. Thevolumedealer

    Thevolumedealer

    Dec 21, 2008
    Good points. They do have excellent customer service. I just don't want to sent it back again since it appears to be otherwise fine.
     
  6. ToadMcFrog

    ToadMcFrog Supporting Member

    Aug 6, 2011
    New Mexico, USA
    The light on my Titan went out a few months ago as well. I contacted Mesa and found that they use a standard #47 bulb, the same bulb that Fender uses in their amps.

    I purchased some of these from Amazon, and they work great.
     
  7. Thevolumedealer

    Thevolumedealer

    Dec 21, 2008
    Thank you so much!
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.