1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Pope Flexcore hiss

Discussion in 'Pickups & Electronics [BG]' started by interp, Nov 18, 2017.


  1. interp

    interp Supporting Member

    Apr 14, 2005
    Garmisch, Germany
    Hi, I have a Yamaha bass with a Mike Pope Flexcore 2.2 stk preamp. Wonderful preamp and I’m very happy with it except for one problem. It has a bass/treble stacked board and a low-mid/high mid stacked board. In active mode the B/T board is dead quiet, whether cut or boosted. The low mid/hi mid board is dead quiet when everything is cut, there is a moderately loud hiss at the detente position, and a VERY loud hiss/white noise when fully boosted.

    The only way I can play the bass in active mode without driving myself crazy is to fully cut the low and high mids, and that of course takes away the whole point of using the preamp.
    I know Mike will be able to troubleshoot this but I wanted to tap the collective wisdom of the TB community first.

    Any ideas? Thanks in advance.

    P.S. Everything—control and pickup cavities, bridge—is fully shielded and grounded.
     
  2. nick333

    nick333

    Nov 3, 2012
    Did you ever find a fix / explanation for this hiss ?
     
  3. interp

    interp Supporting Member

    Apr 14, 2005
    Garmisch, Germany
    I checked the main gain trim pot and found it turned all the way up. Turned it down and that helped significantly. I still need to adjust the center frequencies for the low and hi mids, but I’m waiting on some jumper shunts from Mike Pope to do that.
     

Share This Page