Dismiss Notice

Ready to join TalkBass and start posting, get alerts, sell your gear, and more?  Register your free account in 30 seconds.

sunn beta bass squeak feedback issue

Discussion in 'Amps and Cabs [BG]' started by slm91, Jan 24, 2014.


  1. slm91

    slm91

    Dec 16, 2013
    set up is geddy lee j bass > tuner> boss BOD > sansamp> sunn beta bass.. but for some reason even at low volumes i am getting a squeaky feedback even when i am holding the strings and there should no feedback. ive ruled out the pedals because when they are off i am still having the same issue. ive come to learn that there is very little clean head room with this bass head, but this shoudnt be happening. playing in a punk band guitarist is playing a JCM800 cranked ALL the way. Its very inconsistent. some days it doesnt do it. the next practice i havent touched any of the settings and it acts up...this is very annoying HELP!
     
  2. tom-g

    tom-g

    Oct 2, 2007
    Could be dirty pots.
     
  3. Register_To_Disable

  4. ^This!
    Take it to a tech and him give it a once over... clean up all the pots and chech it over well.
    I have a beta bass amp made in the 80's. I recently had it cleaned and checked over after a few decades of neglect.
    It works as it should now!
    Probably just dirty pots... and the drive pots on that amp do tend to be a bit finiky...
    Fishheadjoe
     
  5. kohntarkosz

    kohntarkosz Banned

    Oct 29, 2013
    Edinburgh - Scotland
    If it hasn't had the caps replaced, it is probably time for that.