1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

TBers help! Cabinet Issue

Discussion in 'Amps and Cabs [BG]' started by obimark, Aug 21, 2012.


  1. obimark

    obimark Supporting Member

    Sep 1, 2011
    Fellow TBers, just need some help and advice.

    I play thru an Aguilar TH 500 head into a Markbass 15 in, CLUB cabinet. (use two cabinets for some gigs -additional 12 in Markbass)

    I have been exploring the PorkLoin pedal and enjoying its goodness, but when I push it some for grind, my cabinet is doing something odd, I guess the closest to call it would be a slight "farting out" type sound.

    I don't believe my cabinet is blown, is there some other explanation for this? Maybe I need to tighten down the screws on it?
     
  2. BongRattlinBass

    BongRattlinBass

    Aug 21, 2012
    Are you playing it fairly overdriven/distorted? You mean Grindcore? I've always had a hard time being able to crank that style of head and use much distortion, I usually have to sacrifice volume. It might be just a frequency issue between the pedal and the head, I could also see having more speakers helping. If your speaker isn't blown, your dust cap might just need reglued, some times being pushed real hard is the only time you notice.
     
  3. murphy

    murphy

    May 5, 2004
    Toronto, Canada
    turn your horn/ tweeter off
     
  4. RickenBoogie

    RickenBoogie

    Jul 22, 2007
    Dallas, TX
    +1 to turn the horn off, and +1 to cutting your low eq.
     
  5. BongRattlinBass

    BongRattlinBass

    Aug 21, 2012
    Oh yeah, I bet it's just your horn if you have one, I never use cabs with one. If its not that, see above or let us know...
     
  6. +1 to all that, and I will add that you might be expecting too much from your speakers. How loudly are you playing?
     

Share This Page