1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

TC Electronic RH450 problem

Discussion in 'Amps and Cabs [BG]' started by TheShape101, Mar 13, 2013.


  1. I was at a gig on Monday night and set up my gear as usual and we did a soundcheck and everything was fine. When I came back to do the gig later on my RH450 wouldn't power up, and hasn't powered up since. Has anybody experienced anything like this? I haven't had any problems with it before this and it showed no signs of any faults leading up to this! I thought it might just be a blown fuse but there's no accessible fuses to check and the units seem pretty well sealed! Does anybody have any ideas what the problem might be?

    Thanks.
     
  2. I'd suggest you start by contacting TC Electronic. For everything else that people have posted, personally, I can't recall seeing where anyone posted about having one die. There are protection mode scenarios referenced in the manual, but it doesn't sound like you have one of those. There's no other troubleshooting you can do. And no fuses.
     
  3. Thanks, yes i mailed TC and I'm just waiting on a reply so i'll see what they say.
     
  4. I hope they get back to you quickly.

    Not that it sounds like there's any likelihood in it, did you by chance try another power cable?
     
  5. Hi drpepper, yes i tried 2 different power cables but unfortunately had no luck. Thanks for the suggestion though. Hopefully I'll hear back from TC soon.
     
  6. arai

    arai Banned

    Jul 16, 2007
    Keep us updated please, I have never heard of this problem before.
    It could be a faulty switch
     
  7. GrowlerBox

    GrowlerBox

    Feb 10, 2010
    Nude Zealand
    New one to me too. Unfortunately any amp can fail, it's how the manufacturer responds that counts. Let's hope they take the opportunity to get it right.
     

Share This Page