1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Warwick Corvette FNA Jazzman Electrics Problem

Discussion in 'Basses [BG]' started by BicBass, Jan 14, 2013.


  1. BicBass

    BicBass

    May 19, 2012
    Northants
    Hi All,

    I'm having trouble with my Warwick Corvette FNA Jazzman. Every time a put a new battery in it, it gets drained within a couple of days, maybe even sooner. It's as if the bass is plugged in constantly and is drawing constant power. Obviously this is really annoying, and I can't really use the bass at the moment, unless I take out the battery every night!

    I wondered if anyone has encountered this problem before, and if there may be a quick fix at all? I'm guessing it's maybe a short-circuit problem somewhere, but I wouldn't really know what to do to fix it, and I don't want to potentially do any further damage inside, because it all looks pretty complex!

    Many thanks in advance,
    Bic.
     
  2. I had the same exact problem with my SS2. I swapped the pups and electronics but you should contact Warwick first.
     
  3. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Mar 1, 2021

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.