1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

4runner Starter Problem, New Starter

Discussion in 'Off Topic [BG]' started by Let It Fall, Oct 19, 2009.


  1. Let It Fall

    Let It Fall Banned

    Oct 15, 2009
    Baton Rouge
    I had starter problems, it was clicking and eventually starting, eventually the starter got stuck in the on position, while engine running, I removed it and got the contacts replaced, 60$ didn't help still clicking..

    Just replaced whole starter.. Still clicking. ***>!?!

    Its getting 12v to the positive side of the starter.. I don't get it!!
     
  2. joegeezer

    joegeezer

    Mar 9, 2005
    Northern Wisconsin
    Avatar Club#12 Eden Club Lucky# 13--USA Peavey Club#37 Carvin Club#5
    Sounds like you have a bad positive battery cable. Check all the places where that cable goes. If it's quite a few places, then open the wallet, and spend the big bucks and buy the new one. Also check if it has loose connections and tighten them first, before buying. I'd bet thats it though.
    It could also be the negative cable. They corrode off inside the jacketing, where you can't see it.
     
  3. Let It Fall

    Let It Fall Banned

    Oct 15, 2009
    Baton Rouge
    Let this be a lesson, before you shell out a lot of money. Check the simple stuff. 60$ repair for the old starter and 100$ for a new starter later, AND it was a 2.50 postive battery terminal..

    I decided to take it off just to clean it or something and upon removal it broke in half.. Replaced it and it works great..

    The old starter I believe DID need to be repaired, which I could have done myself for 25$ but decided to let someone else do it.. However that wasn't the only problem..
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.