1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
  2. Welcome Back!  Please see this thread for more info about the site outage.  Thank you for your patience as we work out bugs and tweak server configs.

Ampeg SVT-410HLF crackling noise: please help diagnose

Discussion in 'Amps and Cabs [BG]' started by Chris 'Wighat' Jordan, Aug 21, 2016.


  1. I had a harrowing experience last Thursday. It was our first time to play at a venue that usually has bigger name/regional acts. I plugged into my SVT-CL/SVT-410HLF rig and there was a thin, fizzy crackling noise. I changed guitar cords. I eliminated pedals, I changed speaker cords. I swapped out the amp. I used a different bass. It was still there. Turned out to be the cabinet. Now, this light crackling isn't the kind of racket that comes from a loose speaker wire. It's not a mechanical sound like a rubbing voice coil or something touching a cone. I checked the speakers anyway. This sound is fairly faint, intermittent, happens playing and not and is light, high-pitched, fizzy crackling and sounds "electrical" in nature. Could it be a bad capacitor on the cross-over board or some such?
     
  2. Tweeter? Try turning it off completely?
     
  3. I did not. I will.
     
    rodl2005 likes this.
  4. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Apr 11, 2021

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.