1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Darkglass Microtubes 900 + DG410C Shuts down on stage

Discussion in 'Amps and Cabs [BG]' started by x-y-z, Dec 27, 2017.


  1. Darkglass

    Darkglass Gold Supporting Member Commercial User

    Dec 10, 2008
    Helsinki, Finland
    Douglas Castro, Founder: darkglass.com
    Oh thank you! Next time I’m in Austin we should prepare a meetup with this group!

    Grab some beers and talk about music and gear.
     
  2. That would be pretty awesome. :D
     
    Darkglass likes this.
  3. Sent my Darkglass head in last Wednesday, Jack received it Monday, fixed it by today and shipped it out... already heading back my way. About 10 days in since I e-mailed support. 2 weeks total down time. Damn impressive customer service and turnaround time. :)
     
  4. Nakoatron

    Nakoatron Supporting Member

    Aug 17, 2017
    Fort Worth, Texas
    Having the same issue. Not pushing the amp hard at all(volume at roughly 10 o'clock, gain set to no clipping) in a 2 hour band practice session it power cycled 5 times on me. At this point I can not afford to replace it for a while. Seriously bummed out.
     
  5. BogeyBass

    BogeyBass

    Sep 14, 2010
    Dam shutdown city.

    Dont sound like voltage in all the cases.
    Sounds like overheating
     
  6. Nakoatron

    Nakoatron Supporting Member

    Aug 17, 2017
    Fort Worth, Texas
    Mine was ice cold.. wasn't on long enough to get warm when it first started

     
    agedhorse likes this.
  7. Mine shut down at a very cold outdoor gig - in the 30's - and also shut down inside at our practice room at normal temperature.
     
  8. Nakoatron

    Nakoatron Supporting Member

    Aug 17, 2017
    Fort Worth, Texas
    Darkglass is issuing an rma for me to get it fixed. I'll keep y'all posted
     
  9. Darkglass

    Darkglass Gold Supporting Member Commercial User

    Dec 10, 2008
    Helsinki, Finland
    Douglas Castro, Founder: darkglass.com
    It is voltage. A few units in that ICEPower module model has had an issue when mains near 100VAC.

    We switched to a new model almost a year ago, no issues since then!

    If anyone has had shut down issues, PM me. I’ll make sure your power module is upgraded and send you a small Darkglass gift for the inconvenience.

    Regards,
    Doug.
     
    Fat_Bottom_End likes this.
  10. BassmanPaul

    BassmanPaul Gold Supporting Member

    Aug 25, 2007
    Toronto Ontario Canada
    American beer? You’ll have to buy an awful lot! LOL :)
     
  11. BassmanPaul

    BassmanPaul Gold Supporting Member

    Aug 25, 2007
    Toronto Ontario Canada
    Quite a while ago I bought myself a cable reel with a nice thick gauge. I unreel the length that I need and find a place to plug it in. I favour going into a kitchen and using one of the outlets on the stove. I never have low voltage problems this way.
     
    kartiste likes this.
  12. Nakoatron

    Nakoatron Supporting Member

    Aug 17, 2017
    Fort Worth, Texas
    Thank you very much for the support and help!!
     
  13. The turnaround time was great, but I didn't get a gift. :laugh:
     

Share This Page