EBS Bass IQ Triple Envelope Filter problem

Discussion in 'Effects [BG]' started by bassmasta94, Mar 23, 2011.


  1. bassmasta94

    bassmasta94

    Jul 21, 2009
    Connecticut
    Hey guys, recently ive been "trying" to play and jam with my envelope filter pedal but for some reason one day i picked it up, it didnt work properly. When i have the effect on i.e: the little red light is on no sound is coming through, but when i take the effect off, and its just coming clean through the pedal is works fine. I tried changing the battery, and doing with an adapter, but the problem is still there. If anyone has this pedal, or has had the same problem and could give me some reasoning, it would be great because im confused as hell.:help:
     
  2. bassmasta94

    bassmasta94

    Jul 21, 2009
    Connecticut
    no one knows?!
     
  3. Bassed in NZ

    Bassed in NZ ...in search of the impeccable groove...

    Feb 22, 2008
    Auckland, New Zealand
    Hey man, I have a BassIQ (& a number of other EBS pedals). Never come across this problem personally or on a forum.

    Guessing that what's happening I when bypassed (which is mechanical) it's passing the signal through ok, but when activated there's something wrong in the electronics.

    Best suggestion is to write to EBS - I've always found then really helpful & responsive.

    Good luck!
     
  4. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Jun 19, 2021

Share This Page