1. Please take 30 seconds to register your free account to post, make friends, earn reward points at our store, remove most ads and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

GK MB210

Discussion in 'Amps and Cabs [BG]' started by strawblues, Mar 20, 2014.


  1. strawblues

    strawblues

    Mar 20, 2014
    Can anyone help? My GK 210 amp, which I have had for 3 tears now and love, failed on the last number of my last gig. The blue light around the switch turned to a flashing red and continued flashing for a while even when I switched it off. Since then I have tried it again, the light turns blue as normal and the amp sounds fine for a short while but then it cuts out and the light starts flashing red again. Anyone had this trouble? Is there a fix?
     
  2. Sounds like it might be a thermal issue since it comes on for a while and then shuts off. Make sure any and all fans are powered on. The hard part about those class Ds are the micro components they all use being a pain in the butt to work on for a typical tech. I hear GK has excellent customer service though, so you might call them up and see if they can shed some light on it and potentially get you a replacement part without costing an arm and a leg.
     
  3. pglaser01

    pglaser01

    Mar 19, 2013
    St. Louis, MO
    If only I were that good....
    Hopefully something hasn't fried out in there...mine is coming up on year 3 so I'm hoping it can last a lot longer still
     
  4. strawblues

    strawblues

    Mar 20, 2014
    Thanks. I've contacted GK they seem to think it might be the power amp module and it won't be a cheap fix!
     
  5. GroovinOnFunk

    GroovinOnFunk Supporting Member

    Apr 30, 2008
    San Diego, CA
    Endorses ClearTone and SIT Strings
    I had to fix that on my MB210 a year or so ago. Ran me close to $300. Sucks... but it's been running strong since.