1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Having issues installing ToneMonster SBK-2 preamp for Peavey Grind

Discussion in 'Pickups & Electronics [BG]' started by Dan B, Feb 24, 2021.


  1. Dan B

    Dan B

    Oct 19, 2008
    Amherst, MA
    So I am unsure if this is in the right section, but I need help installing a ToneMonster SBK-2 preamp I got for my Peavey Grind as the original passive electronics were completely shot and the bass sounded awfully dark. Wiring it up was simple enough as this preamp is solderless, and the diagrams ToneMonster give are easy enough to follow, however, the end result is that my bass has very little output and whatever does sounds farty and unpleasant (as if there was a cheap fuzz permanently installed on the bass). I have tried two different batteries, both new, and I still get the same result. In addition, the EQ knobs don't seem to be doing much of anything.

    I have a few theories as to what it might be:
    - I wired it incorrectly (entirely possible)
    - The preamp itself is damaged and I need to contact Guitar Fuel (the suppliers for this preamp) for a replacement
    - Both batteries I tested were bad
    - The pickups are bad (though I am unsure if this would give this sort of result).

    Any idea what it might be?

    Thanks!
     
  2. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    May 17, 2021

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.