1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Help with Preamp for Yamaha TRB6

Discussion in 'Pickups & Electronics [BG]' started by rybass309, May 24, 2011.


  1. rybass309

    rybass309

    Feb 11, 2011
    CT
  2. Musiclogic

    Musiclogic Commercial User

    Aug 6, 2005
    Southwest Michigan
    Owner/Builder: HJC Customs USA, The Cool Lute, C G O
    I am pretty sure you can use any aftermarket pre, as I think the TRB split coils are passive, and just the pre is the active part.
     
  3. rybass309

    rybass309

    Feb 11, 2011
    CT
    I think you are right. Thanks for the help.
     
  4. ex-tension

    ex-tension

    Jun 11, 2009
    The fried part of the original pre is most probably the opamp. You don't need to buy and change all the parts. Try to replace the opamp with a new one and see if it revives the pre. It's gonna be cheap to try.
     
  5. rybass309

    rybass309

    Feb 11, 2011
    CT
    It's not completely dead. The bass pot had snapped off before I purchased it and replaced with a non-yamaha pot that didn't fit correctly through the body so the threads were not exposed to lock it to the body. Well it went in a case, a little pressure and snap goes the pot. I ordered a new pot from yammy, soldered it to the board and now it has gone haywire. When turning the bass pot from full back to mid point, I get a high pitch squeal.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.