1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Problem with new MIM 09 Precision Bass

Discussion in 'Basses [BG]' started by RogueOne41, Mar 25, 2009.


  1. RogueOne41

    RogueOne41

    Oct 17, 2006
    Scotland
    Hi guys,

    I recently bought one of the new MIM Precision basses. However, I have a problem with it. Whenever the guitar lead is all the way in the jack, the output is very low, muffled and lacking any highs. Whenever, the lead is pulled out slightly so that it is just resting in the jack's socket, the sound seems to come back to what seems like normal.

    Do you know what could be causing this?

    Is this a bad connection with the contact in the jack? What should the angle of the contact be in the jack? The one in my bass is currently not angled at all and points straight down from the jack.

    Thanks for any help
     
  2. It sounds like the side piece of the jack that contacts the cable tip is a little bent. Should be easy enough to remove the jack and bend it back so that the contact is correct.

    Or....ask the shop you bought it from to do it, so the warranty is protected.

    Roger
     
  3. savit260

    savit260

    Mar 6, 2006
    Boston
    Probalby something touching metal that shouldn't be.

    Proabably a VERY easy fix. Take it to the shop you bought it from, and I'm sure they'll have it fixed in a few minutes.

    Could be just a wire rubbing up against the jack or the cord end.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.