1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Squire j bass pu's HELP!!!

Discussion in 'Pickups & Electronics [BG]' started by 8bassist4life8, Mar 7, 2013.


  1. 8bassist4life8

    8bassist4life8

    Sep 24, 2009
    Today while doing some regular work on my squire VM jazz bass I tightened the nuts that go on the volume, tone knobs, and output jack after trying to plug in a d play my bass no sounds comes out and nothing shows up on my tuner. Please help!!!!:thumbdown:
     
  2. Take the bass apart and have a look. I presume you didn't over tighten the nuts? Try another lead as that could be the problem. Don't do anything drastic till you find the fault!

    Davo
     
  3. 8bassist4life8

    8bassist4life8

    Sep 24, 2009
    I think I might ha e over tightened them but then when I loosened them they still didn't work. When I looked under the control plate everything was fine.
     
  4. oldleftybass

    oldleftybass

    Jan 24, 2013
    If you did damage a pot by overtightening (seems like you would have to REALLY overtighten) you have a few options:

    1. Take it to someone
    2. Get a multimeter, open the control cavity and trace the signal path to see where you lose continuity
    3. Replace one pot at a time

    Most likely not the jack. Tightening the pot nut just pulls on the shell of the pot- not the shaft that has the wiper on it, so it's hard to see where overtightening would damage it.
     

Share This Page