1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Ampeg PF350 Fault Light

Discussion in 'Amps, Mics & Pickups [DB]' started by tom grossheider, Nov 17, 2018.


  1. tom grossheider

    tom grossheider

    Oct 14, 2004
    ILLINOIS
    I've read a few threads on this already, as well as some of the poll thread. Bought this one used last year, never cranked it much until a guy drove 2 hours to buy it (I'm using a GK MB800 on a 2x12 cab now) and when we had the volume on 3 o'clock, gain at 12 o'clock it kept cutting out and the fault light came on. Cleaned the speaker contacts, headphone jack, effects loop jacks, tried different cables, added another 8 ohm cab but still cuts out when hitting it a bit hard. I don't think that is normal, and definitely not overheated either. I don't think I'll have any recourse with Ampeg as it is probably long out of warrantee. Obviously I could not sell it in that condition, bummer for both of us. Just looking for some recent thoughts or fixes. There is an Ampeg service guy not too far away, but expensive.
     
  2. Ric Vice

    Ric Vice Supporting Member

    Jul 2, 2005
    Olivette, Missouri

    It never hurts to send Ampeg service a letter explaning the problem. It’s worth a shot. They had some issues with the early runs of this series of amps, more so with the PF 500. The threads on this problem are, as you say lengthy, but generaliy you don’t hear about or see long threads on how good a particular amp line is. :) :D :laugh:
     
    tom grossheider likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.