1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Ampeg SVT 450H, problem

Discussion in 'Amps and Cabs [BG]' started by AKI BASE, May 20, 2011.


  1. AKI BASE

    AKI BASE

    Jul 5, 2008
    ATHENS-GREECE
    Hello to everyone
    After a 3 hour rehearsal, my Ampeg head start to make a noise (like fuzz) every time i played on bass.

    I usually play with the master volume in the end and the gain in 9 o'clock.
    I check everything (bass, cable, cabin), the problem is on the head.
    Please, if anyone can help.......Thank you.!
     
  2. JimmyM

    JimmyM Supporting Member

    Apr 11, 2005
    Apopka, FL
    Endorsing: Ampeg Amps, EMG Pickups
    maybe a bias issue? i know the svt 3 pro requires occasional biasing of the mosfets. maybe this one does, too.
     
  3. RickenBoogie

    RickenBoogie

    Jul 22, 2007
    Dallas, TX
    How exactly do you "know" it's the amp, and not the speakers?
     
  4. craig.p

    craig.p

    Sep 28, 2008
    New Hampshire
    Try isolating the head from the cabinet so it doesn't pick up any cabinet vibrations. If the problem goes away, then you have a loose connection or bad solder joint inside the amp. It could even be dirty contacts in the effects in jack, though I think that's a long shot. But you can eliminate that possibility by connecting the effects out and effects in jacks with an instrument (shielded) cable.
     
  5. AKI BASE

    AKI BASE

    Jul 5, 2008
    ATHENS-GREECE
    Thanks everyone for the replies, i will try your advices......!
     
  6. Jerrold Tiers

    Jerrold Tiers

    Nov 14, 2003
    St Louis
    The 3PRO needs it because the bias is especially sensitive due to the "zero feedback" design.

    The other amps are not like that, and so the bias is less critical.

    There are lots of reasons for a "fuzz-type" tone, ranging from dirty connections to amplifier failures, so any opinion here is pretty useless. Go to a technician.

    If the technician does not have schematics etc, send me a PM with your email..... I should have them.
     
  7. AKI BASE

    AKI BASE

    Jul 5, 2008
    ATHENS-GREECE
    Hello my friend,
    What is the PM ?
     
  8. Jerrold Tiers

    Jerrold Tiers

    Nov 14, 2003
    St Louis
    Sorry...

    PM = "private message" , a feature of this site..... If you click the name on a post, you get a list of actions, one of which is 'send a private message"..... that is what you want.

    Send me your email address that way , and I will email the PDF files to you
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.