Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Another dead Deep Impact?

Discussion in 'Effects [BG]' started by eshears, Feb 21, 2006.


  1. eshears

    eshears Supporting Member

    Jul 30, 2001
    Spokane, WA
    My Akai Deep Impact crapped out.

    I was playing a show a couple of weeks ago, I turned on the Deep Impact, and there was no sound, then it turned off and back on again. I didn't try to use it the rest of the night.

    So I plug it in last week, and it looks like everything is working OK, but when I turn it on...nothing. The clean bass signal is still going through, but the effect doesn't engage. I also noticed that the Input Level lights aren't lighting up.

    What's even worse is that I live in Spokane, WA and as far as I can tell, there isn't an Akai repair shop anywhere near here. Does anybody have any suggestions before I ship it off to VST for repair? I love this freakin' pedal and need it back!
     
  2. ZonPlyr

    ZonPlyr

    Apr 29, 2003
    Pasadena, CA
    may not have anything to do with your problem but when i first got mine i had the same problem kind of. Mine would engage the effect but there was no output, the output level knob would just spin and spin. I took it apart and noticed that the tab that connects the shaft of the pot to the dial on the circuit board wasn't in its slot. I put a drop of ca glue on it and haven't had a problem since.

    Had it been a problem with the board itself i probably wouldn't have messed with it, but since it was mechanical in nature i fixed it. I doubt there is any warranty left on it so you should be able to at least pull the cover and make sure there isn't something obvious that is wrong with it.

    just my $.02
     
  3. eshears

    eshears Supporting Member

    Jul 30, 2001
    Spokane, WA
    I popped open the case already and took a look around. All of the connections look OK, and that's about all I could decipher from looking in there.
     
  4. eshears

    eshears Supporting Member

    Jul 30, 2001
    Spokane, WA
    I've been playing with this a little more, and I've got some more info for any problem solvers out there.

    When I first plug in the Deep Impact and it powers up, I can engage the effect and it will work for a couple of seconds...the Input lights light-up, and I hear the effected sound. And then...PA-BAM! It's gone and all I hear is the clean bass. I have to unplug the Deep Impact from power and then plug it back in in order to do this again.
     
  5. Are you using the original Akai power supply or some other after market replacement? The only time I have had problems with mine, just like your description, was when I was using a different power supply either a 1spot or Boss.
     
  6. eshears

    eshears Supporting Member

    Jul 30, 2001
    Spokane, WA
    I was using a Godlyke power supply, which was working fine for months. When this problem popped up, I tested with the original power supply...same dealio.
     
  7. lbanks

    lbanks

    Jul 17, 2003
    Ennui, IN USA
    My mine died. Where can I get it repaired?
     
  8. Tedintheshed

    Tedintheshed Banned

    Oct 8, 2004
    Columbus, Ohio
    You have to send it to Akai.

    Be prepred.
     
  9. NJL

    NJL

    Apr 12, 2002
    San Antonio
    This is not correct...

    Guys do a search... there's a place in, I think, Pasadena, that works on them... I'm trying really hard to remember the name of the place....

    :)

    If I remember, I'll put the name in this thread.
     
  10. Toasted

    Toasted

    May 26, 2003
    Leeds, UK
    Prepared for what Ted? A big bill? :)
     
  11. lbanks

    lbanks

    Jul 17, 2003
    Ennui, IN USA
    I'll probanly have to sell it to pay for repairs.:bawl:
     
  12. eshears

    eshears Supporting Member

    Jul 30, 2001
    Spokane, WA
    I sent mine here to get repaired: http://www.vstservice.com/

    Yes, they are in Pasadena, CA. I just shipped it to them last week, so I can't review or recommend them yet, but they seem to be about the only place in the US that will repair Akai stuff.
     
  13. NJL

    NJL

    Apr 12, 2002
    San Antonio
    Thanks!!! That's the place!

    :)
     
  14. lbanks

    lbanks

    Jul 17, 2003
    Ennui, IN USA
    That's what I needed! Thanks!
     
  15. eshears

    eshears Supporting Member

    Jul 30, 2001
    Spokane, WA
    Alrighty, VST called me the other day and said they fixed my Deep Impact...they told me that there was a bunch of loose connections on the board. They shipped it out the same day I called with my credit card info, and should be back to me on Wednesday. I'll post again after I plug it in and everything sounds funkilicious.

    All around good service, I'd say (so long as everything works when it gets here). The bill came to under $100, so I can get it fixed a couple more times before it starts costing me more than buying one off eBay!