Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

EBS Bass IQ Problems

Discussion in 'Effects [BG]' started by Pöl, May 2, 2004.


  1. Pöl

    Pöl

    May 31, 2003
    Belgium
    So...
    I bought this bass IQ from EBS. Took it home, plugged in my 9V adapter and... all hum, no sound!!

    What to do?

    I've put in 2 different 9V batteries, didn't word at all.


    Any hints, tips, experiences??

    Thanx
     
  2. Pöl

    Pöl

    May 31, 2003
    Belgium
    bump anyone? :help:
     
  3. David Wilson

    David Wilson Administrator Staff Member Administrator Supporting Member

    Oct 14, 2002
    Lower Westchester, NY
    if you've checked your cabling and are still getting the same results, then take it back for a replacement.

    Personally, I've had three brand new EBS pedals come to me DOA / faulty.
     
  4. anastasio24

    anastasio24

    May 24, 2003
    Maryland
    My first BassIQ was DOA as well. I took it back and they replaced it. A year later I sold it and the guy I sold it to uses it at least three times a week with no problem.

    Once you get a good one they seem to last.
     
  5. David Wilson

    David Wilson Administrator Staff Member Administrator Supporting Member

    Oct 14, 2002
    Lower Westchester, NY
    yeah, I should have said that also. Once I got replacements, they were fine.
     
  6. Pöl

    Pöl

    May 31, 2003
    Belgium
    Problem solved, got a new power supply. Thanks for the help, guys :hyper: