1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Hartke lh500 issue. Popping sound.

Discussion in 'Amps and Cabs [BG]' started by Vamposaur, Jun 7, 2011.


  1. Vamposaur

    Vamposaur

    Jun 4, 2009
    Los Angeles
    I have a hartke lh500 and when I play through it...it works great for a few minutes...then it pops and stops working. What could be the problem here? Of course the guys at guitar center were no help. That's why I came here.
     
  2. glenb73

    glenb73

    Dec 18, 2010
    Guitar center doesn't sell Hartke gear...what makes you think they would help with something they don't even sell?
     
  3. bassssificator

    bassssificator

    Jan 29, 2011
    does you're fan work properly ?

    maybe it's an automatic shutdown due to poor ventiltion !
     
  4. jjk2007

    jjk2007 Supporting Member

    Apr 16, 2008
    Austin, TX
    Endorsing Artist: DNA
    Get in touch with Larry Hartke. He'll help you out.

    201-680-8153
     
  5. RPD

    RPD

    May 18, 2018
     
  6. RPD

    RPD

    May 18, 2018
    Mines doing the same thing. Changed tube. No difference. Will try cleaning tube socket next.
     
  7. agedhorse

    agedhorse SUSPENDED Supporting Member Commercial User

    Feb 12, 2006
    Davis, CA (USA)
    Development Engineer-Mesa, Product Support-Genz Benz
    You know guys, a knowledgeable, qualified service tech could take care of this easily and without guessing (and without the risk of causing additional damage)!
     
    BassmanPaul and jjk2007 like this.
  8. Crystalman85

    Crystalman85

    Nov 30, 2008
    Chicago, Il.
    I have a hartke lh500 and mine works fine. the popping might be from rusty knobs. so you might wanna check that. if the knobs are rusty, contact cleaner should fix that.
     
  9. agedhorse

    agedhorse SUSPENDED Supporting Member Commercial User

    Feb 12, 2006
    Davis, CA (USA)
    Development Engineer-Mesa, Product Support-Genz Benz
    Don't go spraying "miracle fix-all contact cleaner" anywhere until you know exactly what the actual problem is. IF that's the problem (which I doubt in this case) you can end up with a bigger and more expensive mess as ruined pots is a much more expensive outcome.

    The only material that I have seen that is generally safe is DeOxit D5, and only the tiniest amount possible.
     
  10. RPD

    RPD

    May 18, 2018
    I think I have a problem with the differential transistors leaking some DC on speaker outputs and tripping the protect circuit send a message to Larry Hartke earlier in the week have not heard anything back
     
  11. agedhorse

    agedhorse SUSPENDED Supporting Member Commercial User

    Feb 12, 2006
    Davis, CA (USA)
    Development Engineer-Mesa, Product Support-Genz Benz
    Clearly, if that's the case then contact cleaner is not going to help ;)
     
  12. RPD

    RPD

    May 18, 2018
    Lol! Very true!
     
    agedhorse likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.