1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Peavey Combo Amp problem!

Discussion in 'Amps and Cabs [BG]' started by JPhoenix19, Mar 25, 2009.


  1. JPhoenix19

    JPhoenix19

    Mar 5, 2009
    Tampa, FL
    Hey everyone out there in TBville.

    I have a Peavey TKO 115 combo amp from the 90s that has a problem. I'll be playing through it for a while and semingly at random it will suddenly loose significant volume or fade out entirely. If, while it is doing this, you lightly slap the top of the amp, it goes back to normal volume. I have heard a few differing oppinions as to what it could be but I'm wondering if anyone here has experienced a similar problem. I could not find any threads on this subject. I really want to fix this amp because I LOVE it!

    Thanks in advance!
     
  2. kcolyar

    kcolyar

    Feb 28, 2007
    Moab, Ut 84532
    Take it to a dealer. They can fix it. It could be any number of problems. Pre amp shorting out, power amp shorting out, some wire getting hot. My Crate is cutting out right now. After about 5 minutes of playing it just quits. If I plug straight into the power amp input it works. So I am guessing it is my pre amp on the fritz. I would get it checked out though, Peavey's are pretty bullet proof IME.
     
  3. hrgiger

    hrgiger

    Jan 11, 2009

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.