portaflex PF-50T active bass clicking when touching strings, tuners bridge

Discussion in 'Amps and Cabs [BG]' started by jimmyhat1978, Oct 17, 2017.


  1. jimmyhat1978

    jimmyhat1978

    Apr 8, 2015
    I'm gonna throw this out there since I could not find anything out there in the search and interwebs on this. Here is the situation...I have a PF-50T that I have been playing for about a year or so. Up until now I have been playing mostly passive basses. Now when I play an active bass either with it in active or passive mode if I touch the strings, bridge, tuners, knobs, or anything metallic there is a loud click coming from the 410 cab I am running with the PF-50T. I thought maybe it was the grounding on the bass so I had my tech go over it and all is in order. I have tried two different active basses in passive and active mode and they both make the same clicking noise. I have tried different power sources, power conditioning, moving the amp, switching cables, changing batteries, removing the batteries, and the click is still there if you touch anything metallic on the bass. I have no clue what is going on. My non active basses are quiet as can be, with the same amp, cables, ecetera. No clicking or hum...nothing, but the active basses are diving me nuts with this clicking noise. Any help would be appreciated.
     
  2. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Sep 24, 2021

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.