1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Problem with my GK Fusion 550

Discussion in 'Amps and Cabs [BG]' started by MarcGodin, Feb 11, 2013.


  1. MarcGodin

    MarcGodin

    Nov 10, 2009
    Quebec
    I own a Fusion 550 and I have problem with this amp. When I turned it on there a big "pop" and after there a kind of fuzz when I play bass. This "fuzz" disapeared after like 15-20 minutes of playing. I've check everything (basse, cable, cab, the ac outlet) and came to conclusion that the problem come from my amp. I've bought it new and it is no more on the warranty. There is something I can do before putting it in the hands of a technician. thank,
    Marc
     
  2. You can try new preamp tubes first. The top cover not only has screws on top but a couple on the back. The tube shields need to be rotated CCW to remove them, normal care when pulling the tubes and re-inserting the new ones.
     
  3. MarcGodin

    MarcGodin

    Nov 10, 2009
    Quebec
    I will look for the tubes. How can I test a tube to know if its broken. Thanks,
    Marc
     
  4. The MOST reliable way without test equipment is to swap known good new or used tubes in the amp (one at a time).
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.