Schecter Diamond Series Custom 5, Low Thump Noise

Discussion in 'Pickups & Electronics [BG]' started by revampeng, Sep 14, 2017.


  1. revampeng

    revampeng

    Sep 14, 2017
    My Schecter has the EMG-HZ pick-ups which I am not sure if they are active or not. I have a 9V battery but one of the other forums stated that Schecter wired the knobs to the battery not the pick-ups; but I have not torn into it to confirm one way or the other.

    My issue is that I keep getting a low thump noise while not playing. I play at two different churches and have experienced the same phenomenon on both sound systems so that rules out gain, channel, board, cables, direct boxes, amps, etc...bass is the common denominator; in my mind at least. The sound can nearly be described as the kick from the drum kit; I was convinced the drummer was thumping over there in the dead quiet the first time I heard it. During a rehearsal the team watched the board long enough to find that it was the bass channel. I changed cables, tapped all over the bass, turned every knob, jiggled the cable, hit the cable...nothing triggered this thump. It is random whether volume knob up or off. Sound guy just mutes the channel when we aren't playing.

    I still need to swap the battery just to rule that out, but came to this forum to pick your brains on what else may be my culprit.

    Thank you in advance.
     
  2. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Jun 21, 2021

Share This Page