1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Svt III help

Discussion in 'Amps and Cabs [BG]' started by Jgrabs07, Mar 7, 2013.


  1. Jgrabs07

    Jgrabs07

    Apr 26, 2012
    Temple Texas
    I recently bought a used svt 3 got a good deal 350 and its an 06 model, im getting some static when i turn up or down the tube gain, i put three new sov-tecs in the pre still, static through my cabs. Has anyone ran into this prob, thought i mite clean the pots, but i wanted to get some feed back first thanks in advance for the help
     
  2. If it is only when turning the pot then proper clean and lube should take care of it, If not you could have other (still not serious) troubles.
     
  3. Jgrabs07

    Jgrabs07

    Apr 26, 2012
    Temple Texas
    Thanks bstring i was really hoping it wasnt a mosfet science he sold it so cheap, when i turn the knob it takes a second then i hear a little static, could i be turning it to quickly, i herd it controls the power to the au and ax section,after the pre
     
  4. Can't turn it too quickly. Does the noise stop?
     
  5. Jgrabs07

    Jgrabs07

    Apr 26, 2012
    Temple Texas
    I kinda thought so on the turning the pot, im surging to much power to quick, ill still deoxit and see where im at from that point thanks for the help bstring
     
  6. Sorry if what I tried to say confused you. The speed at which you move the pot should not matter. Electrons move a lot faster than you ever could :). Crackling is "usually" a bad resistor and could be affected by quick changes be it from a control or voltage changes from signal applied (cold solder joints are also possible).

    Jerrold Tiers will be by at some point and jump all over whatever I may have stated incorrectly :)
     
  7. Jgrabs07

    Jgrabs07

    Apr 26, 2012
    Temple Texas
    Kool thanks man
     

Share This Page