Amp Problem - Strange clipping?

Discussion in 'Amps and Cabs [BG]' started by GeoS, Mar 8, 2010.


  1. GeoS

    GeoS

    Nov 21, 2009
    Hi, just today I started getting a problem with unwanted distortion. I haven't changed anything recently, so that's not the problem, it's worked perfect till now.

    I'm playing through a GK Backline 115, so not the most quality combo amp in the world but decent enough.

    What is happening is that when I hit the strings hard, it seems to distort heavily. It's NOT to do with the volume of the amp or the bass, it would seem, merely how hard I hit the strings. And it isn't gradual or anything. I play soft and its totally clean. I play hard or slap and it sounds like its going through the distortion channel.

    So I'm assuming this is a problem with the amp, and if anyone has ideas I'd appreciate it. Is it totally blown or is something else to blame? If so, sorry for being a newb!:bawl: Thanks!
     
  2. Rick Auricchio

    Rick Auricchio Registered Bass Offender

    Have you tried another bass? Does yours need a new battery?
     
  3. Vakmere

    Vakmere

    Sep 6, 2007
    Philly
    Hmmm, that could be it or you're playing louder than usual because the gui****s are drowning you out.
     
  4. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Jun 22, 2021

Share This Page