1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Ampeg SVT-2 Pro midrange selector control not working

Discussion in 'Amps and Cabs [BG]' started by spikemacgee, Feb 23, 2008.


  1. spikemacgee

    spikemacgee

    Oct 24, 2007
    Brew City, WI
    :help:

    I have an Ampeg SVT-2 Pro from about 2000 or 2001 and the midrange selector control (five position knob) does not appear to be working. I also have an SVT-3 Pro which essentially has the same preamp and the selector on that makes a pretty big difference. On the SVT-2 Pro I hear no difference in the sound between selections whatsoever.

    I'm wondering if it's a defective switch or could I be lucky and it's just a little dirty? I don't have the schematics but even if I did I'm not smart enough to read them :)

    I'm going to carefully take it apart and check things out but any tips you might have are appreciated.

    Thanks.
     
  2. anderbass

    anderbass

    Dec 20, 2005
    Phoenix. Az.
    When my SVT-II's mid tone knob is nearly centered, I dont notice any difference between my mid frequency positions either.
    Just as a quick test, try pegging your mid tone knob to 10, and then see if your "midrange selector control" becomes more responsive.
     
  3. Warpeg

    Warpeg Supporting Member

    Jun 20, 2005
    Ohio
    You wouldn't be able to notice a difference in the frequency selection when your mid +/- knob is in the middle. When it's in the middle it is set flat, which is to say that it is not boosting or cutting the selected frequency. This is also known as a semi-parametric midrange EQ.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.