1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Ampeg SVT-2 PRO Warming-up/Standby Issue

Discussion in 'Amps and Cabs [BG]' started by jimmykebab, Apr 25, 2010.


  1. jimmykebab

    jimmykebab

    Feb 12, 2008
    Hello.

    I was wondering if anyone else has had issues with their Ampeg SVT-2 Pro taking ages to warm up?

    I can leave if for 20-40 mins and sometimes it just won't switch onto 'on' mode. It's really odd, and a big of a nightmare. Eventually it does switch on, but it's pot luck to guess when that happens.
     
  2. JimmyM

    JimmyM Supporting Member

    Apr 11, 2005
    Apopka, FL
    Endorsing: Ampeg Amps, EMG Pickups
    shop time, dude. at most it should take 30 seconds.
     
  3. pointblank72

    pointblank72

    Dec 14, 2009
    Cairns, QLD
    Yeah, I agree. I have an SVT 2 pro and have never had to wait more than a minute. I know they do have a function in them whereby even if you flick both switches to on straightaway, the light will remain red for about 20 seconds and the amp will remain in the warm up stage.

    I'm no tech but perhaps there could be something wrong with this part of their circuit which is supposed to be a safeguard against just switching on without warm up.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.