1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Calling all computer nerds/voip people! (long shot)

Discussion in 'Off Topic [BG]' started by mattsk42, Dec 3, 2012.

  1. mattsk42

    mattsk42 $100 off new Directv subsp.PM me BEFORE signing up Supporting Member

    I'm running out of ideas, so I'm throwing this up in TB as a super long shot in case someone here is a knowledgeable IT guy. Any help would be really appreciated, and may serve you well in any trades down the road. ;)

    We installed FreePBX distro last week and configured it so that when someone calls in, it goes to all the phones so someone here can answer the call. After trying all the internal extensions, it rolls over to a ring group with Zach's cell phone number in it, then the next ring group called Pause which does nothing and has the number of 0, then the next ring group of Tom's cell phone.
    If it still has not been answered then it goes to a ring group that has the internal "voicemail" number in it. Here, it leaves a voicemail and then emails us the wav file.

    When the system calls the cell phones the person being called has to dial 1 to confirm the call - Zach hasn't been able to answer the call by pressing 1, but Tom can.

    We tried Switching the ring group pointing to Zach to point to a third person, and they were able to confirm calls, so it must be Zac's blackberry that has issues.

    Well, we switch it back, don't change anything else (intentionally). Call in now, and it says "please wait while we transfer you" just like normal, but never rings either cell phone and basically goes straight to voicemail after trying the internal extensions. If we dial JUST the external phone ring groups from our internal phone, it goes to the phone just fine.

    So in summary, something's killing it when going from the ring group for the internal phones to the external cell phone ring groups. What are some settings to look for on this? I can look into settings, I just can't test much until this weekend.
  2. Bting


    Dec 2, 2008
    Do you have to have an number to signify it is going outside the system ie. dial 9, then number.

    Does your local exchange require 10 digits, or only 7

    Did you save the new rule sets? It might require a reboot.

    Does your call timer (if no answer on group "A" after x rings/seconds) need adjustment?

    When you set it to go from Zachs phone, to try it to Tom's phone, did you add Tom to that ring group, or just direct the call to Tom's number. If you just directed teh call to Tom's #, did you reset the ring group up after removing Tom from the equation?

    I know it's nothing Magical, but start at the basics, right?
  3. mattsk42

    mattsk42 $100 off new Directv subsp.PM me BEFORE signing up Supporting Member

    No number to get outside the system, but have to dial 1 to get long distance number (which all 3 cell phones are).

    10 I think.

    Saved and rebooted several times.

    Tried longer and shorter with that and no luck.

    I just replaced the number that gets dialed WITHIN that ring group from Zach's number to Tom's. Left Tom's ring group alone, did not remove. But it still didn't work after I switched that number back.

    Thanks! :hyper:
  4. Bting


    Dec 2, 2008
    I'm not familiar with your software.
    BUt I do have soem expoerience with PBX's at our office.

    YOu will need to verify that you have all 10 numbers in the dialing sequence. 11 as it is long distance.
    Check to make sure you dont have a "toll control" rule that slipped in there.

    Are the calls logged anywhere that you can trace?
    It just sounds suspicions that the calls are bypassing that ring group entirely. I'd think you should get some feedback on a bang/bang situation like that.

    My gut says, the ring group has been removed from the sequence, regardelss of what the console is showing you.
    I'd remove the ring group, apply this new rule set, confirm that as working and then re-introduce the ring group, apply, etc, etc.

    Or maybe try to increase the attempts on that ring group, before it gives up and goes to vmail. Just to see if you get any sort of
    "customer you called cannot be reached"
    fast busy, etc
  5. mattsk42

    mattsk42 $100 off new Directv subsp.PM me BEFORE signing up Supporting Member

    OK, did some more testing, came up more confused. Does anyone here know where to find where all these settings are stored within the OS (not GUI)?

    Here's my post on the other forum:
    It seems like whenever I use the gui, it gets messed up. We had it all working and literally just changed the name of one of them and it killed it.

    1. I'd like to find where the ring groups and extension settings are stored so I don't HAVE to use the GUI, and
    2. I'd like to check them on there to make sure it's not just the GUI reporting things wrong. Also look for any duplicate entries or something that could be causing our problem.

    Here's the previous/current experience. http://www.freepbx.org/forum/freepbx/general-help/cant-call-external-cel...

    Any tips or guides out there?