1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

GK800rb problems, input needed

Discussion in 'Amps and Cabs [BG]' started by bustedamp, Oct 21, 2013.


  1. bustedamp

    bustedamp

    Oct 21, 2013
    So I have a GK800rb that I was using as a power amp with an ADA MB1 preamp plugged into the effects return. After a while of using this configuration I unplugged the preamp and tried to use the 800rb on its own, but it does not work. It powers up, it works fine as a power amp but the preamp section is not working and I cannot use it on its own.

    Is this a common thing? What could have happened to the preamp? I don't have the cash to drop it off at an amp repair place and possibly have to pay a couple hundred bucks to repair it. It is not just a loose input jack. I did not blow it up. I have no idea why the preamp section is not functioning now and would really appreciate any ideas on what went wrong as I love the 800rb and have not been able to use it for a long time.
     
  2. DrewinHouston

    DrewinHouston Not currently practicing Supporting Member

    Apr 20, 2009
    Houston Heights, Texas
    Disclosure: I am not a great bass player
    Try running a cable from the 800RB's preamp output to the power amp input.
     
  3. It is most likely corrosion in the effects return jack bypass contacts. Use an instrument cable from effects send to effects return, if all is well again then the effects return jack needs to be properly cleaned (the return jack's internal contacts connect the pre to power amp with no plug installed).
     
  4. tabdog

    tabdog

    Feb 9, 2011
    Clean the jacks with DOxit.

    Spray it in there and push a male
    jack in and out several times.

    When my 400 RB III was messing
    up, I cleaned all the jacks and the
    pots and have not had any problems
    sense,

    Tabdog
     
  5. JohnnyBottom

    JohnnyBottom Supporting Member

    Nov 27, 2002
    New Jersey
  6. bustedamp

    bustedamp

    Oct 21, 2013
    THANK YOU B-STRING! I'd like to buy you a beer or a doobie, whatever you prefer if I could! I patched a pedal cord between the effects send and return, and my 800rb is BACK!!!! I haven't played it in over 4 years it has just been sitting in a closet because of this issue. I cannot believe I didn't think of this before, I'm aware of the patch cord trick for my peavey 5150 to make it sound better but never thought to try it for this.

    This thing sounds so effing great I missed it so much! I never could get the sound I wanted from my P-bass with the 800rb out of commission. The ADA MB-1 is badass, and I also have a SUNN 200s but the GK is my favorite.

    You guys rock, thanks so much for the tips!
     
  7. A beer is good, Mary Jane and I never saw eye to eye. :D
     
  8. whoatherechunk

    whoatherechunk

    Apr 4, 2008
    "Bustedamp" - best user name ever to post in Amps section haha
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.