1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

New to using effects, and having some trouble

Discussion in 'Effects [BG]' started by calmb4tehpwn, Oct 15, 2013.


  1. Hey guys. I just bought my first real effect pedal a couple weeks ago. The Darkglass VMT, and I didn't realize it didn't come with a power supply, so I went ahead and ordered one which arrived today.

    Now, when I plug everything in I get absolutely no sound. The light comes on the VMT, and when I turn it off, the passthrough works just fine, but with the pedal on, I get the blue light and no sound. I've fiddled with the knobs, and this seems the case at all settings.

    Am I just missing something? Or did I get bad pedal?

    I'm not one to just go returning something, because it's generally not fair to the company that made it, so I want to exhaust all my resources before I send this back.

    Additionally, I'm with the US Army, stationed in Korea, so getting this back out, and a new one to me, could take upwards of two months, which I am not really willing to wait.

    Is there a way to test if it's a certain issue? I do have some electronics repair experience, but nothing like pedals. I've mostly worked on desoldering and soldering PCBs. That said, if it's an issue I can fix, I can probably fix it, but I'd need to find out what the issue is first.

    Thanks, guys.
     
  2. bongomania

    bongomania Commercial User

    Oct 17, 2005
    PDX, OR
    owner, OVNIFX and OVNILabs
    Did you order the power supply from Darkglass, or where? Are you sure the ps is meant for the voltage in your region, and that it puts out 9v dc ( not ac) and that the plug polarity is correct?
     
  3. mouthmw

    mouthmw

    Jul 19, 2009
    Croatia
    You didn't mention which power supply you got. Kind of an important info.
     
  4. Sorry, it's a Planetwaves power supply. It's a 9vdc power supply, with the correct polarity and is the correct voltage for the region.
     
  5. bongomania

    bongomania Commercial User

    Oct 17, 2005
    PDX, OR
    owner, OVNIFX and OVNILabs
    Are there any other pedals also hooked up to that supply?
     
  6. Grissle

    Grissle

    May 17, 2009
    Ok don't hit me, is the bass plugged into the input of the pedal or the output? Sounds dumb but I've seen people new to effects plug into the output.
     
  7. holy CRAP I feel like an idiot. I tend to consider myself a pretty intelligent fellow, but in my excitement never doublechecked. I think the fact that pass-through worked when it was turned off, made me never doubt that I had it plugged up the right way.

    I was totally hooking up output -> input.

    Thanks for calling me on it, Grissle.
     
  8. DagoMaino

    DagoMaino

    Feb 1, 2013
    ha ha... good call!
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.